summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-31 18:34:02 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-31 13:05:19 +0200
commita84a74f618b0d3eadea622a45f62c9401c4f82ba (patch)
treeb1b85488613c20e8ee001e388ffbedb6db4c0042 /include/image-commands.mk
parentf29774bee35928d5efc09910568775bd2cecf423 (diff)
downloadmaster-31e0f0ae-a84a74f618b0d3eadea622a45f62c9401c4f82ba.tar.gz
master-31e0f0ae-a84a74f618b0d3eadea622a45f62c9401c4f82ba.tar.bz2
master-31e0f0ae-a84a74f618b0d3eadea622a45f62c9401c4f82ba.zip
scripts/ubinize-image.sh: add support for adding custom partitions
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 00cb3410e9..40a9619c31 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -114,6 +114,7 @@ define Build/append-ubi
sh $(TOPDIR)/scripts/ubinize-image.sh \
$(if $(UBOOTENV_IN_UBI),--uboot-env) \
$(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
+ $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
$(IMAGE_ROOTFS) \
$@.tmp \
-p $(BLOCKSIZE) -m $(PAGESIZE) \