summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-14 13:51:49 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-15 14:18:14 +0200
commit7bdc21de7241f779146be2dd7c77bb3a8067a672 (patch)
tree5fd7fa7e433d27f31152e21f878ee2cff19171a7 /include/image-commands.mk
parentb948c9371b2bce7b5c3ca5812cc4b9d9a02b49b9 (diff)
downloadmaster-31e0f0ae-7bdc21de7241f779146be2dd7c77bb3a8067a672.tar.gz
master-31e0f0ae-7bdc21de7241f779146be2dd7c77bb3a8067a672.tar.bz2
master-31e0f0ae-7bdc21de7241f779146be2dd7c77bb3a8067a672.zip
image.mk: fix append-dtb race when multiple devices use the same .dts
Call Image/BuildDTB unconditionally to keep things consistent Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 17ab46d859..1128aeab6d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -39,8 +39,8 @@ define Build/tplink-safeloader
endef
define Build/append-dtb
- $(if $(DEVICE_DTS_DIR),$(call Image/BuildDTB,$(DEVICE_DTS_DIR)/$(DEVICE_DTS).dts,$(DTS_DIR)/$(DEVICE_DTS).dtb))
- cat $(DTS_DIR)/$(DEVICE_DTS).dtb >> $@
+ $(call Image/BuildDTB,$(if $(DEVICE_DTS_DIR),$(DEVICE_DTS_DIR),$(DTS_DIR))/$(DEVICE_DTS).dts,$@.dtb)
+ cat $@.dtb >> $@
endef
define Build/fit