summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-13 17:23:00 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-14 10:27:30 +0200
commitb8fddb8912dfe1d2405b685680f7bb1a0b10937a (patch)
tree91a0918d45b04ab078fedde7a85b7510bfed14a0 /include/image-commands.mk
parente0ed6ec667c74ae48694808626d3bf00bea12b2b (diff)
downloadmaster-31e0f0ae-b8fddb8912dfe1d2405b685680f7bb1a0b10937a.tar.gz
master-31e0f0ae-b8fddb8912dfe1d2405b685680f7bb1a0b10937a.tar.bz2
master-31e0f0ae-b8fddb8912dfe1d2405b685680f7bb1a0b10937a.zip
image: allow devices to override the -E 5 ubinize option
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index e8549d46f6..17ab46d859 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -105,8 +105,9 @@ define Build/append-ubi
$(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
$(word 2,$^) \
$@.tmp \
- -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5 \
- $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE))
+ -p $(BLOCKSIZE) -m $(PAGESIZE) \
+ $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+ $(UBINIZE_OPTS)
cat $@.tmp >> $@
rm $@.tmp
endef