summaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-20 08:46:08 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-20 10:13:50 +0200
commit9a50a213d225263985eef5a4ab7870ff2c0925cf (patch)
tree1fe434b46c8b105c048aea3304457b7724df1dfa /include/image-commands.mk
parentcd243b1090952b1bb12d94e07825e450ca3d5118 (diff)
downloadmaster-31e0f0ae-9a50a213d225263985eef5a4ab7870ff2c0925cf.tar.gz
master-31e0f0ae-9a50a213d225263985eef5a4ab7870ff2c0925cf.tar.bz2
master-31e0f0ae-9a50a213d225263985eef5a4ab7870ff2c0925cf.zip
image.mk: add support for specifying the VID header offset for UBI
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 1128aeab6d..fc36509efd 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -107,6 +107,7 @@ define Build/append-ubi
$@.tmp \
-p $(BLOCKSIZE) -m $(PAGESIZE) \
$(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+ $(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
$(UBINIZE_OPTS)
cat $@.tmp >> $@
rm $@.tmp