summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-05 18:45:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-05 18:45:20 +0000
commit40ab15892dbf9b2a3f2a9f7737de374c94733925 (patch)
treec7f4546e08bde3e10bf7d1ff139809779aee426e /include/host.mk
parent3a4d04f6ec3fe876617686535f4fbed4b4409a09 (diff)
downloadmaster-31e0f0ae-40ab15892dbf9b2a3f2a9f7737de374c94733925.tar.gz
master-31e0f0ae-40ab15892dbf9b2a3f2a9f7737de374c94733925.tar.bz2
master-31e0f0ae-40ab15892dbf9b2a3f2a9f7737de374c94733925.zip
Abstracted find to $(FIND) to allow use of gfind on non-GNU systems.
Signed-off-by: Andy Boyett <agb-openwrt@padded-cell.net> SVN-Revision: 9659
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/host.mk b/include/host.mk
index d163c997dd..00eb1f55aa 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -30,6 +30,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
TAR=`which gtar 2>/dev/null`; \
[ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
echo "TAR:=$$TAR" >> $@; \
+ FIND=`which gfind 2>/dev/null`; \
+ [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
+ echo "FIND:=$$FIND" >> $@; \
echo "BASH:=$(shell which bash)" >> $@; \
if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
echo 'FIND_L=find -L $$(1)' >>$@; \