summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-16 07:19:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-16 07:19:45 +0000
commit3e87d642f7592ae71078c4c3d725a4a0104901c7 (patch)
treeca6c3063077484dd3ac14f29888f11a0c07a4759 /include/host.mk
parent2809e403d6246076eb3f884c9137a3269a027e39 (diff)
downloadmaster-31e0f0ae-3e87d642f7592ae71078c4c3d725a4a0104901c7.tar.gz
master-31e0f0ae-3e87d642f7592ae71078c4c3d725a4a0104901c7.tar.bz2
master-31e0f0ae-3e87d642f7592ae71078c4c3d725a4a0104901c7.zip
detect whether the find command supports -L or -follow
SVN-Revision: 8002
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/host.mk b/include/host.mk
index 833aa83a66..cc0436e7b0 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-include $(TMP_DIR)/.host.mk
+-include $(TMP_DIR)/.host.mk
export TAR
@@ -29,6 +29,11 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
[ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
echo "TAR:=$$TAR" >> $@; \
echo "BASH:=$(shell which bash)" >> $@; \
+ if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+ echo 'FIND_L=find -L $$(1)' >>$@; \
+ else \
+ echo 'FIND_L=find $$(1) -follow' >> $@; \
+ fi; \
)
endif