summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-07 11:33:12 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-07 11:33:12 +0000
commit3cf0250da20f230a3edbe585bd16fdd19576851e (patch)
tree0b3dd2d569e494e5c535142cfb479da72bbd8865 /include/host.mk
parentd3f412f4ec3a6e47297ab22c60208394aed9b03c (diff)
downloadmaster-31e0f0ae-3cf0250da20f230a3edbe585bd16fdd19576851e.tar.gz
master-31e0f0ae-3cf0250da20f230a3edbe585bd16fdd19576851e.tar.bz2
master-31e0f0ae-3cf0250da20f230a3edbe585bd16fdd19576851e.zip
host.mk: introduce PATCH which refers to either gpatch or patch
SVN-Revision: 23287
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/host.mk b/include/host.mk
index f3e47c8723..9b8a32b672 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -59,6 +59,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
else \
echo 'XARGS:=xargs' >> $@; \
fi; \
+ PATCH=`which gpatch 2>/dev/null`; \
+ [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
+ echo "PATCH:=$$PATCH" >> $@; \
)
endif