summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-07-01 21:38:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-07-01 21:38:28 +0000
commit171e7134db9ab6166aa97eddcc00beec81f9f35f (patch)
tree69e15d3055a36dbb7b5909c1937b431d852a6b09 /include/host.mk
parent979fb5a23e515714462f880238af6c3c42b4eb05 (diff)
downloadmaster-31e0f0ae-171e7134db9ab6166aa97eddcc00beec81f9f35f.tar.gz
master-31e0f0ae-171e7134db9ab6166aa97eddcc00beec81f9f35f.tar.bz2
master-31e0f0ae-171e7134db9ab6166aa97eddcc00beec81f9f35f.zip
improve xargs compatibility check (mostly Darwin/Mac OS X related)
SVN-Revision: 11613
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/include/host.mk b/include/host.mk
index 00eb1f55aa..9d40ec40a3 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -39,12 +39,11 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
else \
echo 'FIND_L=find $$(1) -follow' >> $@; \
fi; \
+ if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
+ echo 'XARGS:=xargs -r' >> $@; \
+ else \
+ echo 'XARGS:=xargs' >> $@; \
+ fi; \
)
endif
-
-ifeq ($(HOST_OS),Linux)
- XARGS:=xargs -r
-else
- XARGS:=xargs
-endif