summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-05 16:57:31 +0000
commit16e1d82460ce939daeceac857c2de207e34468c7 (patch)
tree9a6522c47a98d2f80bf3d4df1108fcbfa1137023 /include/host.mk
parent78f476ed025db36a801c1bfeff025444ac1d702d (diff)
downloadmaster-31e0f0ae-16e1d82460ce939daeceac857c2de207e34468c7.tar.gz
master-31e0f0ae-16e1d82460ce939daeceac857c2de207e34468c7.tar.bz2
master-31e0f0ae-16e1d82460ce939daeceac857c2de207e34468c7.zip
include: remove host command tests from host.mk
Those tests are part of prereq-build.mk now. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44273
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk28
1 files changed, 6 insertions, 22 deletions
diff --git a/include/host.mk b/include/host.mk
index 000fb18984..4ca81400e9 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,8 +10,6 @@ ifeq ($(if $(TARGET_BUILD),,$(DUMP)),)
-include $(TMP_DIR)/.host.mk
endif
-export TAR FIND
-
ifneq ($(__host_inc),1)
__host_inc:=1
@@ -41,25 +39,11 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
echo "HOST_OS:=$$HOST_OS" > $@; \
echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
- TAR=`which gtar 2>/dev/null`; \
- [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which gnutar 2>/dev/null`; \
- [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
- echo "TAR:=$$TAR" >> $@; \
- FIND=`which gfind 2>/dev/null`; \
- [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
- echo "FIND:=$$FIND" >> $@; \
- echo "BASH:=$(shell which bash)" >> $@; \
- if $$FIND -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
- echo "FIND_L=$$FIND -L \$$(1)" >>$@; \
+ if gfind -L /dev/null || find -L /dev/null; then \
+ echo "FIND_L=find -L \$$(1)" >> $@; \
else \
- echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
- fi; \
- PATCH=`which gpatch 2>/dev/null`; \
- [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
- echo "PATCH:=$$PATCH" >> $@; \
- PYTHON=`which python2.7 2>/dev/null`; \
- [ -n "$$PYTHON" -a -x "$$PYTHON" ] || PYTHON=`which python 2>/dev/null`; \
- echo "PYTHON:=$$PYTHON" >> $@; \
- )
+ echo "FIND_L=find \$$(1) -follow" >> $@; \
+ fi \
+ ) >/dev/null 2>/dev/null
endif