summaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-05-02 17:22:01 +0000
committerNicolas Thill <nico@openwrt.org>2010-05-02 17:22:01 +0000
commit08be2bcfd99a2bf96fb3618db3572fdabd122716 (patch)
treef19d945f2703204b66757e9cfd8d7ab909813ba4 /include/host.mk
parent3b5689eb5ea065b17dbf16ecaec078a1261060e1 (diff)
downloadmaster-31e0f0ae-08be2bcfd99a2bf96fb3618db3572fdabd122716.tar.gz
master-31e0f0ae-08be2bcfd99a2bf96fb3618db3572fdabd122716.tar.bz2
master-31e0f0ae-08be2bcfd99a2bf96fb3618db3572fdabd122716.zip
buildsystem: add a macro to test options supported by the host compiler
SVN-Revision: 21304
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/include/host.mk b/include/host.mk
index b93ab8d536..02365d9eab 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -14,6 +14,17 @@ export TAR FIND
ifneq ($(__host_inc),1)
__host_inc:=1
+
+try-run = $(shell set -e; \
+ TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
+ if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \
+ rm -f "$$TMP_F"; \
+)
+
+host-cc-option = $(call try-run, \
+ $(HOSTCC) $(HOST_CFLAGS) $(1) -c -xc /dev/null -o "$$TMP_F",$(1),$(2) \
+)
+
.PRECIOUS: $(TMP_DIR)/.host.mk
$(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
@mkdir -p $(TMP_DIR)