summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-23 09:50:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-23 09:50:01 +0000
commited2bf29be5ea97f67c7195cd02eaf1bc1515bd36 (patch)
tree4421970d33eba53699af86dd05308c3428b44402 /include/host-build.mk
parent5c88d907c87b6f8c848bb16e079d760f0d5e6edb (diff)
downloadmaster-31e0f0ae-ed2bf29be5ea97f67c7195cd02eaf1bc1515bd36.tar.gz
master-31e0f0ae-ed2bf29be5ea97f67c7195cd02eaf1bc1515bd36.tar.bz2
master-31e0f0ae-ed2bf29be5ea97f67c7195cd02eaf1bc1515bd36.zip
build: add the + token to any commands that can pass through the jobserver, fixes parallel build on some systems
SVN-Revision: 33523
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 66795c8e10..60b7b9f916 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -80,7 +80,7 @@ ifneq ($(HOST_OS),Darwin)
endif
define Host/Configure/Default
- (cd $(HOST_BUILD_DIR)/$(3); \
+ $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
if [ -x configure ]; then \
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
$(2) \
@@ -97,7 +97,7 @@ define Host/Configure
endef
define Host/Compile/Default
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
+ +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
$(HOST_MAKE_FLAGS) \
$(1)
endef