summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 02:20:34 +0000
commitddcfaeb1e516d569436c3d4d453a9573655ca375 (patch)
tree94b1169c72a68b9ef6ce9ab92aea68eb8764358a /include/host-build.mk
parent7ef6b7451973d0d3fd09014871e7859b6a83fb19 (diff)
downloadmaster-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.tar.gz
master-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.tar.bz2
master-31e0f0ae-ddcfaeb1e516d569436c3d4d453a9573655ca375.zip
move host build in packages into a separate namespace: package/<name>/host/<target> this allows dependencies between host and target packages, and saves unnecessary host builds for packages that contain both variants
SVN-Revision: 14905
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk16
1 files changed, 11 insertions, 5 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a0ffd83b6e..892cde91f5 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -12,6 +12,7 @@ include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
+BUILD_TYPES += host
HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
@@ -122,7 +123,12 @@ ifndef DUMP
host-install: $(HOST_STAMP_INSTALLED)
endif
- $(if $(STAMP_BUILT),compile: host-install)
+ ifndef STAMP_BUILT
+ prepare: host-prepare
+ compile: host-compile
+ install: host-install
+ clean: host-clean
+ endif
host-prepare: $(HOST_STAMP_PREPARED)
host-configure: $(HOST_STAMP_CONFIGURED)
host-compile: $(HOST_STAMP_BUILT)
@@ -135,10 +141,10 @@ ifndef DUMP
endef
download:
- prepare: host-prepare
- compile: host-compile
- install: host-install
- clean: host-clean
+ prepare:
+ compile:
+ install:
+ clean:
endif