summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-13 19:04:33 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-13 19:04:33 +0000
commitdbf8d9c516cc7c2826cc7b77cf3bed6edcc4f308 (patch)
treeaf7547cab6a660a509490bb526a10f0805cbcd7d /include/host-build.mk
parent135cfe50c90da2c191bd769afd9043a6480f084d (diff)
downloadmaster-31e0f0ae-dbf8d9c516cc7c2826cc7b77cf3bed6edcc4f308.tar.gz
master-31e0f0ae-dbf8d9c516cc7c2826cc7b77cf3bed6edcc4f308.tar.bz2
master-31e0f0ae-dbf8d9c516cc7c2826cc7b77cf3bed6edcc4f308.zip
- implement hooks for hostbuilds - use host build hooks to implement fixups for host build - move separator declaration to rules.mk
SVN-Revision: 24551
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 161192c3bb..dbd1c3aa45 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -30,6 +30,7 @@ override MAKEFLAGS=
include $(INCLUDE_DIR)/download.mk
include $(INCLUDE_DIR)/quilt.mk
+include $(INCLUDE_DIR)/autotools.mk
Host/Patch:=$(Host/Patch/Default)
ifneq ($(strip $(HOST_UNPACK)),)
@@ -130,12 +131,16 @@ ifndef DUMP
$(HOST_STAMP_PREPARED):
@-rm -rf $(HOST_BUILD_DIR)
@mkdir -p $(HOST_BUILD_DIR)
+ $(foreach hook,$(Hooks/HostPrepare/Pre),$(call $(hook))$(sep))
$(call Host/Prepare)
+ $(foreach hook,$(Hooks/HostPrepare/Post),$(call $(hook))$(sep))
touch $$@
$(call Host/Exports,$(HOST_STAMP_CONFIGURED))
$(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
+ $(foreach hook,$(Hooks/HostConfigure/Pre),$(call $(hook))$(sep))
$(call Host/Configure)
+ $(foreach hook,$(Hooks/HostConfigure/Post),$(call $(hook))$(sep))
touch $$@
$(call Host/Exports,$(HOST_STAMP_BUILT))
@@ -151,17 +156,23 @@ ifndef DUMP
update: host-update
$(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+ $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
$(call Host/Compile)
+ $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
touch $$@
$(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Install)
+ $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
mkdir -p $$(shell dirname $$@)
touch $$@
else
$(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
+ $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
$(call Host/Compile)
+ $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
$(call Host/Install)
+ $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
touch $$@
endif
host-prepare: $(HOST_STAMP_PREPARED)
@@ -182,4 +193,3 @@ ifndef DUMP
clean:
endif
-