summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-05 20:15:12 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-05 20:15:12 +0000
commitcf7199f48b5ef5edbeca7b0d02e1c448c8e1785d (patch)
treea2eb985c3fee20ca21da2e073ff781ff0d8a33f9 /include/host-build.mk
parent0e0bf71ed982211d00813140b2c6771733ee0661 (diff)
downloadmaster-31e0f0ae-cf7199f48b5ef5edbeca7b0d02e1c448c8e1785d.tar.gz
master-31e0f0ae-cf7199f48b5ef5edbeca7b0d02e1c448c8e1785d.tar.bz2
master-31e0f0ae-cf7199f48b5ef5edbeca7b0d02e1c448c8e1785d.zip
this patch fixes toolchain parallel build, which reduces build time.
In order to enable parallel build, change line 21 of include/host-build.mk from: override MAKEFLAGS= to: override MAKEFLAGS=$(MAKE_JOBS) -Raphael SVN-Revision: 19995
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 6324276a70..75792579eb 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -80,7 +80,7 @@ define Host/Compile
endef
define Host/Install/Default
- $(MAKE) -C $(HOST_BUILD_DIR) install
+ $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
endef
define Host/Install