summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-14 00:00:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-14 00:00:55 +0000
commitc99c9f875eeb73448fe8951d16409be5a2dda076 (patch)
treeb160ae508bb3b44353ed0df2fa5b6a3cc8912520 /include/host-build.mk
parent923bef167811193709477894074b00fba7fb21f0 (diff)
downloadmaster-31e0f0ae-c99c9f875eeb73448fe8951d16409be5a2dda076.tar.gz
master-31e0f0ae-c99c9f875eeb73448fe8951d16409be5a2dda076.tar.bz2
master-31e0f0ae-c99c9f875eeb73448fe8951d16409be5a2dda076.zip
build: set CCACHE_DIR for host builds
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45427
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 2f3c53d098..760d38b371 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -131,6 +131,7 @@ define Host/Exports/Default
$(1) : export STAGING_PREFIX=$$(STAGING_DIR_HOST)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+ $(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache
endef
Host/Exports=$(Host/Exports/Default)