summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-12 14:07:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-12 14:07:08 +0000
commitb29f9112df3f22febb5890380ee459da33e29ef8 (patch)
tree2725a4315842b7944cb47a8a16ff33a4241e6c83 /include/host-build.mk
parent252c2229f844ba2f09de1efa4e7fae4e3fb92fbd (diff)
downloadmaster-31e0f0ae-b29f9112df3f22febb5890380ee459da33e29ef8.tar.gz
master-31e0f0ae-b29f9112df3f22febb5890380ee459da33e29ef8.tar.bz2
master-31e0f0ae-b29f9112df3f22febb5890380ee459da33e29ef8.zip
make the compile: host-install dependency independent of the order in which the makefiles were included
SVN-Revision: 14853
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index e92c7b3e68..a0ffd83b6e 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -122,7 +122,7 @@ ifndef DUMP
host-install: $(HOST_STAMP_INSTALLED)
endif
- download:
+ $(if $(STAMP_BUILT),compile: host-install)
host-prepare: $(HOST_STAMP_PREPARED)
host-configure: $(HOST_STAMP_CONFIGURED)
host-compile: $(HOST_STAMP_BUILT)
@@ -134,8 +134,9 @@ ifndef DUMP
endef
+ download:
prepare: host-prepare
- compile: host-compile $(if $(STAMP_BUILT),host-install)
+ compile: host-compile
install: host-install
clean: host-clean