summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 18:10:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 18:10:05 +0000
commitaa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d (patch)
tree5e0e39f175532ad6e626f77994a14c87013e35cc /include/host-build.mk
parentbc6fcb0067e2af16337cd3144c4c5ab532f09ac0 (diff)
downloadmaster-31e0f0ae-aa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d.tar.gz
master-31e0f0ae-aa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d.tar.bz2
master-31e0f0ae-aa0778f77efb1d5c0d49e66a9d52ff438bc1ba7d.zip
allow concurrent use of host-build.mk and package.mk as well as their templates
SVN-Revision: 14621
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk35
1 files changed, 20 insertions, 15 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 3f714cd682..2ce3e1598d 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -6,7 +6,7 @@
#
HOST_BUILD_DIR ?= $(BUILD_DIR_HOST)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
-PKG_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
+HOST_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
@@ -86,9 +86,10 @@ define Download/default
MD5SUM:=$(PKG_MD5SUM)
endef
-define HostBuild
+ifndef DUMP
+ define HostBuild
$(if $(QUILT),$(Host/Quilt))
- $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
+ $(if $(STAMP_PREPARED),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
$(if $(DUMP),,$(call HostHost/Autoclean))
$(HOST_STAMP_PREPARED):
@@ -111,21 +112,25 @@ define HostBuild
touch $$@
ifdef Host/Install
- install: $(HOST_STAMP_INSTALLED)
+ host-install: $(HOST_STAMP_INSTALLED)
endif
- package-clean: FORCE
+ download:
+ host-prepare: $(HOST_STAMP_PREPARED)
+ host-configure: $(HOST_STAMP_CONFIGURED)
+ host-compile: $(HOST_STAMP_BUILT)
+ host-install:
+ host-clean: FORCE
$(call Host/Clean)
$(call Host/Uninstall)
- rm -f $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+ rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
- download:
- prepare: $(HOST_STAMP_PREPARED)
- configure: $(HOST_STAMP_CONFIGURED)
- compile: $(HOST_STAMP_BUILT)
- install:
- clean: FORCE
- $(call Host/Clean)
- rm -rf $(HOST_BUILD_DIR)
+ endef
+
+ prepare: host-prepare
+ compile: host-compile
+ install: host-install
+ clean: host-clean
+
+endif
-endef