summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 03:21:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 03:21:52 +0000
commit9b96b24e32a12f925ba792e9e397044b5413d21d (patch)
tree3306291e5dc696b6c9ec2b9849f841289d1cff6b /include/host-build.mk
parent510bdd3f0ee6b843120d68c68dfd648ec498a357 (diff)
downloadmaster-31e0f0ae-9b96b24e32a12f925ba792e9e397044b5413d21d.tar.gz
master-31e0f0ae-9b96b24e32a12f925ba792e9e397044b5413d21d.tar.bz2
master-31e0f0ae-9b96b24e32a12f925ba792e9e397044b5413d21d.zip
fix quilt variable and stampfile usage for host builds
SVN-Revision: 14910
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a6118fb06f..3d1983b28f 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -13,7 +13,7 @@ include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
BUILD_TYPES += host
-HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
+HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(HOST_QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
@@ -78,7 +78,7 @@ define Host/Compile
$(call Host/Compile/Default)
endef
-ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
+ifneq ($(if $(HOST_QUILT),,$(CONFIG_AUTOREBUILD)),)
define HostHost/Autoclean
$(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))
$(if $(if $(Host/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(HOST_BUILD_DIR),$(HOST_STAMP_BUILT)))
@@ -96,7 +96,7 @@ endef
ifndef DUMP
define HostBuild
- $(if $(QUILT),$(Host/Quilt))
+ $(if $(HOST_QUILT),$(Host/Quilt))
$(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
$(if $(DUMP),,$(call HostHost/Autoclean))
@@ -128,6 +128,8 @@ ifndef DUMP
compile: host-compile
install: host-install
clean: host-clean
+ else
+ host-compile: $(HOST_STAMP_INSTALLED)
endif
host-prepare: $(HOST_STAMP_PREPARED)
host-configure: $(HOST_STAMP_CONFIGURED)