summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:25 +0000
commit94a96244f6db24adedcb3e6f3be07c7cafa484e9 (patch)
treea43d5158a4311922901750527a536f36e3f45255 /include/host-build.mk
parentb942309f4fb6b9268b59466e830e31fdea1f5f71 (diff)
downloadmaster-31e0f0ae-94a96244f6db24adedcb3e6f3be07c7cafa484e9.tar.gz
master-31e0f0ae-94a96244f6db24adedcb3e6f3be07c7cafa484e9.tar.bz2
master-31e0f0ae-94a96244f6db24adedcb3e6f3be07c7cafa484e9.zip
host-build.mk: define a variable HOST_STATIC_LINKING which is set to "-static" on non-Darwin systems
SVN-Revision: 33138
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 6fc29b3a97..a8bc79ea67 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -65,6 +65,10 @@ HOST_CONFIGURE_ARGS = \
HOST_CONFIGURE_CMD = ./configure
+ifneq ($(HOST_OS),Darwin)
+ HOST_STATIC_LINKING = -static
+endif
+
define Host/Configure/Default
(cd $(HOST_BUILD_DIR)/$(3); \
if [ -x configure ]; then \