summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-15 13:19:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-15 13:19:41 +0000
commit6d1884c583d7de97aecb6ea7c4cba9bf6de08e2a (patch)
tree806330874b4db67a8e79d549a2da9a9da1079ae8 /include/host-build.mk
parent14e14faa0b1f376555771bbc811e557f380ad4d2 (diff)
downloadmaster-31e0f0ae-6d1884c583d7de97aecb6ea7c4cba9bf6de08e2a.tar.gz
master-31e0f0ae-6d1884c583d7de97aecb6ea7c4cba9bf6de08e2a.tar.bz2
master-31e0f0ae-6d1884c583d7de97aecb6ea7c4cba9bf6de08e2a.zip
build: fix host build stampfile usage, fixes spurious errors with missing opkg host binary after deleting the staging dir
SVN-Revision: 33776
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk37
1 files changed, 13 insertions, 24 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 60b7b9f916..320e74ee47 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -164,42 +164,31 @@ ifndef DUMP
touch $$@
$(call Host/Exports,$(HOST_STAMP_BUILT))
- ifdef Host/Install
- host-install: $(if $(STAMP_BUILT),$(HOST_STAMP_BUILT),$(HOST_STAMP_INSTALLED))
- endif
-
- ifndef STAMP_BUILT
- prepare: host-prepare
- compile: host-compile
- install: host-install
- clean: host-clean
- update: host-update
- refresh: host-refresh
-
- $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+ $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
$(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
$(call Host/Compile)
$(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
touch $$@
- $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
+ $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Install)
$(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
mkdir -p $$(shell dirname $$@)
touch $$@
- else
- $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
- $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
- $(call Host/Compile)
- $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
- $(call Host/Install)
- $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
- touch $$@
+
+ ifndef STAMP_BUILT
+ prepare: host-prepare
+ compile: host-compile
+ install: host-install
+ clean: host-clean
+ update: host-update
+ refresh: host-refresh
endif
+
host-prepare: $(HOST_STAMP_PREPARED)
host-configure: $(HOST_STAMP_CONFIGURED)
- host-compile: $(HOST_STAMP_BUILT)
- host-install:
+ host-compile: $(HOST_STAMP_BUILT) $(if $(STAMP_BUILT),$(HOST_STAMP_INSTALLED))
+ host-install: $(HOST_STAMP_INSTALLED)
host-clean: FORCE
$(call Host/Clean)
$(call Host/Uninstall)