summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-22 22:05:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-22 22:05:55 +0000
commit63129f9b4c90013989b7e4bd5689b558dd218d27 (patch)
tree68007520eb00ed2d6ba4930a036467db95e98cc9 /include/host-build.mk
parentbb0448739c43cec63134dca8e4fca3d28444e12e (diff)
downloadmaster-31e0f0ae-63129f9b4c90013989b7e4bd5689b558dd218d27.tar.gz
master-31e0f0ae-63129f9b4c90013989b7e4bd5689b558dd218d27.tar.bz2
master-31e0f0ae-63129f9b4c90013989b7e4bd5689b558dd218d27.zip
clean up automake/pkg-config handling, move separate host/package variable exports to templates, fix automake path for host builds
SVN-Revision: 15339
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 1a794846bb..af46c3e245 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -103,6 +103,14 @@ define Download/default
MD5SUM:=$(PKG_MD5SUM)
endef
+define Host/Exports/Default
+ $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-*),-I $$(p))
+ $(1) : export STAGING_PREFIX=$$(STAGING_DIR_HOST)
+ $(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
+ $(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+endef
+Host/Exports=$(Host/Exports/Default)
+
ifndef DUMP
define HostBuild
$(if $(HOST_QUILT),$(Host/Quilt))
@@ -115,12 +123,12 @@ ifndef DUMP
$(call Host/Prepare)
touch $$@
- $(HOST_STAMP_CONFIGURED) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
- $(HOST_STAMP_CONFIGURED) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+ $(call Host/Exports,$(STAMP_CONFIGURED))
$(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
$(call Host/Configure)
touch $$@
+ $(call Host/Exports,$(STAMP_BUILT))
$(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
$(call Host/Compile)
touch $$@