summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:06 +0000
commit35073025b49729e1ec78c2006f9c7eaaeb854a0c (patch)
treef13b6eb9a6520e3f634f6e1bf9526d3a4f892c93 /include/host-build.mk
parent69c1c6ed2828c772234f1379a1b3ff4c28e0226d (diff)
downloadmaster-31e0f0ae-35073025b49729e1ec78c2006f9c7eaaeb854a0c.tar.gz
master-31e0f0ae-35073025b49729e1ec78c2006f9c7eaaeb854a0c.tar.bz2
master-31e0f0ae-35073025b49729e1ec78c2006f9c7eaaeb854a0c.zip
add a default template for Host/Install
SVN-Revision: 15110
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 39de66bb9f..ffba12b51d 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -78,6 +78,15 @@ define Host/Compile
$(call Host/Compile/Default)
endef
+define Host/Install/Default
+ $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Install
+ $(call Host/Install/Default)
+endef
+
+
ifneq ($(if $(HOST_QUILT),,$(CONFIG_AUTOREBUILD)),)
define HostHost/Autoclean
$(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))