summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
commit29b91ef01a0ad053119a3fd6d1d7b91dd7946de9 (patch)
tree6494f4f5fe38ce6f3fc737c7046edfb8ff86476b /include/host-build.mk
parent8c3ea37f2f51d11563c93250846c00141af09ec3 (diff)
downloadmaster-31e0f0ae-29b91ef01a0ad053119a3fd6d1d7b91dd7946de9.tar.gz
master-31e0f0ae-29b91ef01a0ad053119a3fd6d1d7b91dd7946de9.tar.bz2
master-31e0f0ae-29b91ef01a0ad053119a3fd6d1d7b91dd7946de9.zip
introduce a menuconfig option to turn off static linking of host utilities
SVN-Revision: 33154
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a8bc79ea67..40af5c87cc 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -66,7 +66,9 @@ HOST_CONFIGURE_ARGS = \
HOST_CONFIGURE_CMD = ./configure
ifneq ($(HOST_OS),Darwin)
- HOST_STATIC_LINKING = -static
+ ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+ HOST_STATIC_LINKING = -static
+ endif
endif
define Host/Configure/Default