summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-11-03 14:58:32 +0000
committerMichael Büsch <mb@bu3sch.de>2010-11-03 14:58:32 +0000
commit050902efd70bf8d4c88c8ce4124bd8cbe15548c7 (patch)
tree06ce65551e4782323464ffab8d8802f561fa0942 /include/host-build.mk
parentf75ac90b695da2226a25c47d30156983df87ec7b (diff)
downloadmaster-31e0f0ae-050902efd70bf8d4c88c8ce4124bd8cbe15548c7.tar.gz
master-31e0f0ae-050902efd70bf8d4c88c8ce4124bd8cbe15548c7.tar.bz2
master-31e0f0ae-050902efd70bf8d4c88c8ce4124bd8cbe15548c7.zip
deptest: Install of host tools has to be forced for every test, because the host staging dir is cleaned prior a test.
SVN-Revision: 23825
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 1b7f354066..6f742d28a1 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -153,12 +153,12 @@ ifndef DUMP
$(call Host/Compile)
touch $$@
- $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+ $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Install)
mkdir -p $$(shell dirname $$@)
touch $$@
else
- $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+ $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Compile)
$(call Host/Install)
touch $$@