summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 18:28:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 18:28:25 +0000
commitb04f09245d34b51c05f3420bae23d69b70afa3f4 (patch)
tree5fc797b088c87c99f30b6d55aa5de65645d2f042 /include/host-build.mk
parent653f61fb3eb23d5cd30e1577190af038a6a47fbd (diff)
downloadmaster-31e0f0ae-b04f09245d34b51c05f3420bae23d69b70afa3f4.tar.gz
master-31e0f0ae-b04f09245d34b51c05f3420bae23d69b70afa3f4.tar.bz2
master-31e0f0ae-b04f09245d34b51c05f3420bae23d69b70afa3f4.zip
add auto-rebuild for host builds (tested with tools/ and toolchain/)
SVN-Revision: 6361
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk22
1 files changed, 12 insertions, 10 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 0502d7682a..1511242f95 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -73,6 +73,15 @@ ifneq ($(strip $(PKG_SOURCE)),)
endif
define HostBuild
+ ifeq ($(DUMP),)
+ ifeq ($(CONFIG_AUTOREBUILD),y)
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(PKG_FILE_DEPEND)),$(PKG_BUILD_DIR))
+ $$(info Forcing package rebuild)
+ $(PKG_BUILD_DIR)/.prepared: package-clean
+ endif
+ endif
+ endif
+
$(PKG_BUILD_DIR)/.prepared:
@-rm -rf $(PKG_BUILD_DIR)
@mkdir -p $(PKG_BUILD_DIR)
@@ -92,7 +101,7 @@ define HostBuild
touch $$@
ifdef Build/Install
- install-targets: $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed
+ install: $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed
endif
package-clean: FORCE
@@ -103,16 +112,9 @@ define HostBuild
download:
prepare: $(PKG_BUILD_DIR)/.prepared
configure: $(PKG_BUILD_DIR)/.configured
-
- compile-targets: $(PKG_BUILD_DIR)/.built
- compile: compile-targets
-
- install-targets:
- install: install-targets
-
- clean-targets:
+ compile: $(PKG_BUILD_DIR)/.built
+ install:
clean: FORCE
- @$(MAKE) clean-targets
$(call Build/Clean)
rm -rf $(PKG_BUILD_DIR)