summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-03 07:33:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-03 07:33:00 +0000
commit5e406f0a282871d0e1043bebeb4320de64d1fda0 (patch)
tree08ebb39a2f3a21ff9553bbe837e4ecafa9bca3da /include/host-build.mk
parent396895e6d88bb0c9adae73f6f75b47f90cd29c9b (diff)
downloadmaster-31e0f0ae-5e406f0a282871d0e1043bebeb4320de64d1fda0.tar.gz
master-31e0f0ae-5e406f0a282871d0e1043bebeb4320de64d1fda0.tar.bz2
master-31e0f0ae-5e406f0a282871d0e1043bebeb4320de64d1fda0.zip
enable quilt for host builds and add some additional checks
SVN-Revision: 7473
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 83d80bedd5..b5c2a2203d 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -13,12 +13,13 @@ STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell find ${CURDIR} $(PKG_FILE_DEP
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
+include $(INCLUDE_DIR)/quilt.mk
+
+Build/Patch:=$(Build/Patch/Default)
ifneq ($(strip $(PKG_UNPACK)),)
define Build/Prepare/Default
$(PKG_UNPACK)
- @if [ -d ./patches ]; then \
- $(PATCH) $(PKG_BUILD_DIR) ./patches; \
- fi
+ $(Build/Patch)
endef
endif