summaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
commit0d9ddef0e843133bd0cebdbfe141486fee4a6db8 (patch)
tree8aa331ac11110222623f5bf881856433d0b71682 /include/host-build.mk
parentfdbd2f0907990c720505e4b3a1b18d1c470db7c8 (diff)
downloadmaster-31e0f0ae-0d9ddef0e843133bd0cebdbfe141486fee4a6db8.tar.gz
master-31e0f0ae-0d9ddef0e843133bd0cebdbfe141486fee4a6db8.tar.bz2
master-31e0f0ae-0d9ddef0e843133bd0cebdbfe141486fee4a6db8.zip
move common unpacking code to unpack.mk, replace zcat with $(ZCAT) for systems that use gzcat instead
SVN-Revision: 5070
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk8
1 files changed, 2 insertions, 6 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a1287da475..858eee5318 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -6,13 +6,9 @@
#
include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/unpack.mk
-ifneq ($(strip $(PKG_CAT)),)
- ifeq ($(PKG_CAT),unzip)
- UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
- else
- UNPACK=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
- endif
+ifneq ($(strip $(UNPACK)),)
define Build/Prepare/Default
$(UNPACK)
@if [ -d ./patches ]; then \