summaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-16 10:30:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-16 10:30:16 +0000
commit4f73613c2698346102741b27a8524076eb66c20c (patch)
tree727277be70edf937665d9297cf7770c5e9975675 /include/feeds.mk
parent7949a3d381d6d53cc03a2ec87bac19f2490d96f1 (diff)
downloadmaster-31e0f0ae-4f73613c2698346102741b27a8524076eb66c20c.tar.gz
master-31e0f0ae-4f73613c2698346102741b27a8524076eb66c20c.tar.bz2
master-31e0f0ae-4f73613c2698346102741b27a8524076eb66c20c.zip
build: improve feed handling for opkg.conf
- Consider not installed feeds as well - Add option to decide whether to comment disabled feeds Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 42931
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 97b14491f0..695b03b145 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -10,10 +10,12 @@
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
-FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
PKG_CONFIG_DEPENDS += \
CONFIG_PER_FEED_REPO \
+ CONFIG_PER_FEED_REPO_ADD_DISABLED \
+ CONFIG_PER_FEED_REPO_ADD_COMMENTED \
$(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
# 1: package name