summaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-06-16 11:41:52 +0200
committerFelix Fietkau <nbd@nbd.name>2016-06-16 11:56:24 +0200
commit4b8ba2b4cefd3e7a6be832d646b01be4ae97f075 (patch)
tree30eed626c6778aec28cfac600c59d22fde32ad93 /include/feeds.mk
parent3ee6c17cd14ec1fed0b0491542c499c03fc6d211 (diff)
downloadmaster-31e0f0ae-4b8ba2b4cefd3e7a6be832d646b01be4ae97f075.tar.gz
master-31e0f0ae-4b8ba2b4cefd3e7a6be832d646b01be4ae97f075.tar.bz2
master-31e0f0ae-4b8ba2b4cefd3e7a6be832d646b01be4ae97f075.zip
include/feeds.mk: allow installation from feed packages that are installed but no longer in feeds.conf
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index d0d473983e..9526e34706 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -8,8 +8,8 @@
-include $(TMP_DIR)/.packagesubdirs
-FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
+FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))