summaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
commit0333da8943275324d366d562b70f90febbe97e7d (patch)
treed01138f8aa9c91cccbf8e85e4fe0f4bb27d602d4 /include/feeds.mk
parent96afb90f3f96c15cd4bfd6a050538292074cf9da (diff)
downloadmaster-31e0f0ae-0333da8943275324d366d562b70f90febbe97e7d.tar.gz
master-31e0f0ae-0333da8943275324d366d562b70f90febbe97e7d.tar.bz2
master-31e0f0ae-0333da8943275324d366d562b70f90febbe97e7d.zip
include: group kmod ipk files into a "kernel" subdirectory
This is useful to just use the kmods from an official build while supplying base packages from a custom feed or the other way around; for just overriding the kmods with a local repo while using official repos for the rest. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 48475
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index b1a8f81da9..4f71b39940 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
--include $(TMP_DIR)/.packagefeeds
+-include $(TMP_DIR)/.packagesubdirs
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
@@ -21,7 +21,7 @@ PKG_CONFIG_DEPENDS += \
# 1: package name
define FeedPackageDir
$(strip $(if $(CONFIG_PER_FEED_REPO), \
- $(abspath $(PACKAGE_DIR)/$(if $(Package/$(1)/feed),$(Package/$(1)/feed),base)), \
+ $(abspath $(PACKAGE_DIR)/$(if $(Package/$(1)/subdir),$(Package/$(1)/subdir),base)), \
$(PACKAGE_DIR)))
endef
@@ -29,7 +29,7 @@ endef
define FeedSourcesAppend
( \
$(strip $(if $(CONFIG_PER_FEED_REPO), \
- $(foreach feed,base $(FEEDS_ENABLED),echo "src/gz %n_$(feed) %U/$(feed)";) \
+ $(foreach feed,base kernel $(FEEDS_ENABLED),echo "src/gz %n_$(feed) %U/$(feed)";) \
$(if $(CONFIG_PER_FEED_REPO_ADD_DISABLED), \
$(foreach feed,$(FEEDS_DISABLED),echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$(feed) %U/$(feed)";)) \
, \