summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-02-20 04:48:07 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-02-20 04:48:07 +0000
commitf04ad5bb5fbc60ba061f1614ab0441607511c303 (patch)
tree957ddb8905a5fa3b9a6c0a2bb4b10e22f4d417ef /include/download.mk
parent25a5fab34cf89baeed19155baad430ccf6c56709 (diff)
downloadmaster-31e0f0ae-f04ad5bb5fbc60ba061f1614ab0441607511c303.tar.gz
master-31e0f0ae-f04ad5bb5fbc60ba061f1614ab0441607511c303.tar.bz2
master-31e0f0ae-f04ad5bb5fbc60ba061f1614ab0441607511c303.zip
this patch adds support for bzr in include/download.mk, and fixes whitespace.
-Raphael SVN-Revision: 19769
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk51
1 files changed, 33 insertions, 18 deletions
diff --git a/include/download.mk b/include/download.mk
index a50a5e9362..e19cd41476 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
# Try to guess the download method from the URL
-define dl_method
+define dl_method
$(strip \
$(if $(2),$(2), \
$(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://% file://%,$(1)),default, \
@@ -16,9 +16,9 @@ $(strip \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \
$(if $(filter hg://%,$(1)),hg, \
- unknown \
- ) \
- ) \
+ unknown \
+ ) \
+ ) \
) \
) \
) \
@@ -26,7 +26,7 @@ $(strip \
)
endef
-# code for creating tarballs from cvs/svn/git/hg checkouts - useful for mirror support
+# code for creating tarballs from cvs/svn/git/bzr/hg checkouts - useful for mirror support
dl_pack/bz2=$(TAR) cfj $(1) $(2)
dl_pack/gz=$(TAR) cfz $(1) $(2)
dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
@@ -49,19 +49,18 @@ endef
define DownloadMethod/cvs
$(call wrap_mirror, \
echo "Checking out files from the cvs repository..."; \
- mkdir -p $(TMP_DIR)/dl && \
- cd $(TMP_DIR)/dl && \
- rm -rf $(SUBDIR) && \
- [ \! -d $(SUBDIR) ] && \
- cvs -d $(URL) co $(VERSION) $(SUBDIR) && \
- find $(SUBDIR) -name CVS | xargs rm -rf && \
- echo "Packing checkout..." && \
- $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
- mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
- )
+ mkdir -p $(TMP_DIR)/dl && \
+ cd $(TMP_DIR)/dl && \
+ rm -rf $(SUBDIR) && \
+ [ \! -d $(SUBDIR) ] && \
+ cvs -d $(URL) co $(VERSION) $(SUBDIR) && \
+ find $(SUBDIR) -name CVS | xargs rm -rf && \
+ echo "Packing checkout..." && \
+ $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+ mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+ )
endef
-
define DownloadMethod/svn
$(call wrap_mirror, \
echo "Checking out files from the svn repository..."; \
@@ -93,6 +92,21 @@ define DownloadMethod/git
)
endef
+define DownloadMethod/bzr
+ $(call wrap_mirror, \
+ echo "Checking out files from the bzr repository..."; \
+ mkdir -p $(TMP_DIR)/dl && \
+ cd $(TMP_DIR)/dl && \
+ rm -rf $(SUBDIR) && \
+ [ \! -d $(SUBDIR) ] && \
+ bzr co --lightweight -r$(VERSION) $(URL) $(SUBDIR) && \
+ find $(SUBDIR) -name .bzr | xargs rm -rf && \
+ echo "Packing checkout..." && \
+ $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+ mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+ )
+endef
+
define DownloadMethod/hg
$(call wrap_mirror, \
echo "Checking out files from the hg repository..."; \
@@ -111,6 +125,7 @@ endef
Validate/cvs=VERSION SUBDIR
Validate/svn=VERSION SUBDIR
Validate/git=VERSION SUBDIR
+Validate/bzr=VERSION SUBDIR
Validate/hg=VERSION SUBDIR
define Download/Defaults