summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-12 12:18:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-12 12:18:36 +0000
commitef437f5e67adbe2ac2d7cb17dd38f12d9ed4be52 (patch)
tree7410ca17381705c3e2555c0e94d72a50d26fe7d7 /include/download.mk
parentd8c79faf4190c45ebb37b9a2e346c37994debedf (diff)
downloadmaster-31e0f0ae-ef437f5e67adbe2ac2d7cb17dd38f12d9ed4be52.tar.gz
master-31e0f0ae-ef437f5e67adbe2ac2d7cb17dd38f12d9ed4be52.tar.bz2
master-31e0f0ae-ef437f5e67adbe2ac2d7cb17dd38f12d9ed4be52.zip
SVN checkouts should be made non-interactive, so that https repositories with auto-signed repositories can be checked out without user interaction
SVN-Revision: 11785
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 0558d4979e..74986be598 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -67,7 +67,7 @@ define DownloadMethod/svn
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- svn co -r$(VERSION) $(URL) $(SUBDIR) && \
+ svn co --non-interactive -r$(VERSION) $(URL) $(SUBDIR) && \
find $(SUBDIR) -name .svn | xargs rm -rf && \
echo "Packing checkout..." && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \