summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-21 23:02:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-21 23:02:06 +0000
commitb568a64f8c1f7c077c83d8c189d4c84ca270aeb4 (patch)
treea5f9c3173414ff472630a1e319645d796caf5677 /include/download.mk
parent48c8a8ddb09ee4808f2ae72e4220ec0e88f53c4d (diff)
downloadmaster-31e0f0ae-b568a64f8c1f7c077c83d8c189d4c84ca270aeb4.tar.gz
master-31e0f0ae-b568a64f8c1f7c077c83d8c189d4c84ca270aeb4.tar.bz2
master-31e0f0ae-b568a64f8c1f7c077c83d8c189d4c84ca270aeb4.zip
add support for md5sum checks for mirrored tarballs of packages with version control source urls
SVN-Revision: 26260
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index fd197ea216..7009bfcd44 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -45,7 +45,7 @@ define DownloadMethod/default
endef
define wrap_mirror
- $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) ),$(1))
+ $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
endef
define DownloadMethod/cvs
@@ -158,6 +158,7 @@ define Download/Defaults
MD5SUM:=
SUBDIR:=
MIRROR:=1
+ MIRROR_MD5SUM:=x
VERSION:=
endef