summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-02-17 08:44:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-02-17 08:44:37 +0000
commitac5b226735008bd44532b0fd2abf296e6e9f13c2 (patch)
treec0668fadf305a53343f0488f4d70312343110f99 /include/download.mk
parentabeaff88ac6ae8e593de338fba20c3a1eeb25529 (diff)
downloadmaster-31e0f0ae-ac5b226735008bd44532b0fd2abf296e6e9f13c2.tar.gz
master-31e0f0ae-ac5b226735008bd44532b0fd2abf296e6e9f13c2.tar.bz2
master-31e0f0ae-ac5b226735008bd44532b0fd2abf296e6e9f13c2.zip
download.mk: fix packed checkout mirroring support
Changeset r48416 broke the downloading of mirrored, packed scm checkouts. Fix this by removing the "@" sign in front of the download command which is now executed as part of a larger shell command under flock. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 48733
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 8619734d17..988542f95a 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -48,7 +48,7 @@ define DownloadMethod/default
endef
define wrap_mirror
- $(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" "" || ( $(1) ),$(1))
+$(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" "" || ( $(1) ),$(1))
endef
define DownloadMethod/cvs