summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 21:31:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 21:31:50 +0000
commita81ad971df86f8c3b098a333ac868079ff279cc8 (patch)
tree915ce56ff7264799a52f897e10a07fa251368623 /include/download.mk
parent8977571d7f4624f0056a7805899a02028f71786c (diff)
downloadmaster-31e0f0ae-a81ad971df86f8c3b098a333ac868079ff279cc8.tar.gz
master-31e0f0ae-a81ad971df86f8c3b098a333ac868079ff279cc8.tar.bz2
master-31e0f0ae-a81ad971df86f8c3b098a333ac868079ff279cc8.zip
build: add locking for downloads (fixes race conditions with multiple variants)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48416
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index ca5eee4e02..ffde522923 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -182,6 +182,6 @@ define Download
$(DL_DIR)/$(FILE):
mkdir -p $(DL_DIR)
- $(if $(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/unknown))
+ $(call locked,$(if $(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/unknown)),$(FILE))
endef