summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-08-29 13:02:05 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-08-29 13:02:05 +0000
commita35b2385aea357be3735fe65a85768531b6aeb08 (patch)
treef23471c7c1bc9e7a567547443bda1192ad6d9db6 /include/download.mk
parentc37665895b813bafd2d4e2b50add2dbf0cfc2bc6 (diff)
downloadmaster-31e0f0ae-a35b2385aea357be3735fe65a85768531b6aeb08.tar.gz
master-31e0f0ae-a35b2385aea357be3735fe65a85768531b6aeb08.tar.bz2
master-31e0f0ae-a35b2385aea357be3735fe65a85768531b6aeb08.zip
this adds hg (Mercurial) SCM checkout support, very similar to the current git or svn checkout support; potential use is for building em28xx-new driver (USB hybrid DVB-T device) which lives in a Mercurial repo. (#3229)
Signed-off-by: Peter Meerwald <pmeerw@pmeerw.net> SVN-Revision: 12433
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk22
1 files changed, 20 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index a8e0e99f3f..406afee48e 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -15,7 +15,9 @@ $(strip \
$(if $(filter git://%,$(1)),git, \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \
- unknown \
+ $(if $(filter hg://%,$(1)),hg, \
+ unknown \
+ ) \
) \
) \
) \
@@ -24,7 +26,7 @@ $(strip \
)
endef
-# code for creating tarballs from cvs/svn/git checkouts - useful for mirror support
+# code for creating tarballs from cvs/svn/git/hg checkouts - useful for mirror support
dl_pack/bz2=$(TAR) cfj $(1) $(2)
dl_pack/gz=$(TAR) cfz $(1) $(2)
dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
@@ -91,9 +93,25 @@ define DownloadMethod/git
)
endef
+define DownloadMethod/hg
+ $(call wrap_mirror, \
+ echo "Checking out files from the hg repository..."; \
+ mkdir -p $(TMP_DIR)/dl && \
+ cd $(TMP_DIR)/dl && \
+ rm -rf $(SUBDIR) && \
+ [ \! -d $(SUBDIR) ] && \
+ hg clone -r $(VERSION) $(URL) $(SUBDIR) && \
+ find $(SUBDIR) -name .hg | xargs rm -rf && \
+ echo "Packing checkout..." && \
+ $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+ mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+ )
+endef
+
Validate/cvs=VERSION SUBDIR
Validate/svn=VERSION SUBDIR
Validate/git=VERSION SUBDIR
+Validate/hg=VERSION SUBDIR
define Download/Defaults
URL:=