summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-10-10 15:01:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-10-10 15:01:50 +0000
commit97fc11af79f76c467abf512c55bd88b288d87b38 (patch)
tree5e91cc1ee204e51b854d3939941b6c9887350b55 /include/download.mk
parent5380fa27e987854a7b1f2336cd9af4cb0edbe540 (diff)
downloadmaster-31e0f0ae-97fc11af79f76c467abf512c55bd88b288d87b38.tar.gz
master-31e0f0ae-97fc11af79f76c467abf512c55bd88b288d87b38.tar.bz2
master-31e0f0ae-97fc11af79f76c467abf512c55bd88b288d87b38.zip
Incorrect checkout of git submodules
When checking out git packages, buildroot doesn't seem to track the revisions correctly of any submodules referenced by that project. As a result, the submodule stays at whatever revision was referenced by the head of the master branch. Running a 'git submodule update' after the checkout fixes this problem. Signed-off-by: Owen Kirby <osk@exegin.com> SVN-Revision: 38359
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 372db03194..1c3f23e94b 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -88,7 +88,7 @@ define DownloadMethod/git
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
git clone $(URL) $(SUBDIR) --recursive && \
- (cd $(SUBDIR) && git checkout $(VERSION)) && \
+ (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \
echo "Packing checkout..." && \
rm -rf $(SUBDIR)/.git && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \