summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-19 17:16:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-19 17:16:25 +0000
commit71f2a68d525a616dc140f465e79f062c10362ba8 (patch)
tree3b2e6d220ffc3dad43c767c951bcde2962707bfe /include/download.mk
parent1b55cf14cc793ee2806c56c90424f64bac1e107f (diff)
downloadmaster-31e0f0ae-71f2a68d525a616dc140f465e79f062c10362ba8.tar.gz
master-31e0f0ae-71f2a68d525a616dc140f465e79f062c10362ba8.tar.bz2
master-31e0f0ae-71f2a68d525a616dc140f465e79f062c10362ba8.zip
make cvs checkouts more flexible. packages must now specify either -r <tag> or -D <date> in their source revision specification. previously date based checkouts were not supported
SVN-Revision: 14566
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 7a4d90da98..0a2dd3c03f 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -53,7 +53,7 @@ define DownloadMethod/cvs
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- cvs -d $(URL) co -r $(VERSION) $(SUBDIR) && \
+ cvs -d $(URL) co $(VERSION) $(SUBDIR) && \
find $(SUBDIR) -name CVS | xargs rm -rf && \
echo "Packing checkout..." && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \