summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJens Muecke <jens@nons.de>2012-03-17 21:33:13 +0000
committerJens Muecke <jens@nons.de>2012-03-17 21:33:13 +0000
commit62045534504974141683b8515b45d2909672b7bf (patch)
treedb016549c25ceead4f099b0ceb04e6de43e14301 /include/download.mk
parentdeac1c16a1b983a7dddd7d697da9abdd1766ac8a (diff)
downloadmaster-31e0f0ae-62045534504974141683b8515b45d2909672b7bf.tar.gz
master-31e0f0ae-62045534504974141683b8515b45d2909672b7bf.tar.bz2
master-31e0f0ae-62045534504974141683b8515b45d2909672b7bf.zip
Enable recursive download of git sources.
SVN-Revision: 30967
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 7009bfcd44..6cc10d95c3 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -87,7 +87,7 @@ define DownloadMethod/git
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- git clone $(URL) $(SUBDIR) && \
+ git clone $(URL) $(SUBDIR) --recursive && \
(cd $(SUBDIR) && git checkout $(VERSION)) && \
echo "Packing checkout..." && \
rm -rf $(SUBDIR)/.git && \