summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-23 01:21:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-23 01:21:50 +0000
commit40781b7290e9bd313deeefd93b6e119cc61d7809 (patch)
tree4ca382b52349c8eabac369990cdb05576404a471 /include/download.mk
parent0ddd7f10825a80ca6f3af00579f18d75b1a9c10d (diff)
downloadmaster-31e0f0ae-40781b7290e9bd313deeefd93b6e119cc61d7809.tar.gz
master-31e0f0ae-40781b7290e9bd313deeefd93b6e119cc61d7809.tar.bz2
master-31e0f0ae-40781b7290e9bd313deeefd93b6e119cc61d7809.zip
the svn fallback code added in r20322 is evaluated with each make invocation and produces a lot of spurious "svn: broken pipe" error - replace it with a more efficient version
SVN-Revision: 20377
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/include/download.mk b/include/download.mk
index 2d3f35fee9..c924ca0516 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -63,12 +63,6 @@ define DownloadMethod/cvs
)
endef
-SVN_VERSION=$(shell svn --version | head -1 | awk '{ print $3 }' | cut -d. -f2)
-ifeq ($(SVN_VERSION),5)
-else
-SVN_OPTS:=--trust-server-cert
-endif
-
define DownloadMethod/svn
$(call wrap_mirror, \
echo "Checking out files from the svn repository..."; \
@@ -76,7 +70,9 @@ define DownloadMethod/svn
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- svn export --non-interactive $(SVN_OPTS) -r$(VERSION) $(URL) $(SUBDIR) && \
+ ( svn help export | grep -q trust-server-cert && \
+ svn export --non-interactive --trust-server-cert -r$(VERSION) $(URL) $(SUBDIR) || \
+ svn export --non-interactive -r$(VERSION) $(URL) $(SUBDIR) ) && \
echo "Packing checkout..." && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/ && \