summaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:40 +0000
commit224760dee7a5f0913d894b7a23cc8d94b353dd70 (patch)
tree22913c0d4285a39280e60ed103f8f7872fcef437 /include/download.mk
parent029df8cc2e5f5f49d9dea1863fd9a9f37af7ccc0 (diff)
downloadmaster-31e0f0ae-224760dee7a5f0913d894b7a23cc8d94b353dd70.tar.gz
master-31e0f0ae-224760dee7a5f0913d894b7a23cc8d94b353dd70.tar.bz2
master-31e0f0ae-224760dee7a5f0913d894b7a23cc8d94b353dd70.zip
add git checkout support
SVN-Revision: 9553
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk20
1 files changed, 18 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 3866242805..3c7cb7e77b 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -46,7 +46,7 @@ endef
define DownloadMethod/svn
$(call wrap_mirror, \
- echo "Checking out files from svn repository..."; \
+ echo "Checking out files from the svn repository..."; \
mkdir -p $(TMP_DIR)/dl && \
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
@@ -59,8 +59,24 @@ define DownloadMethod/svn
)
endef
+define DownloadMethod/git
+ $(call wrap_mirror, \
+ echo "Checking out files from the git repository..."; \
+ mkdir -p $(TMP_DIR)/dl && \
+ cd $(TMP_DIR)/dl && \
+ rm -rf $(SUBDIR) && \
+ [ \! -d $(SUBDIR) ] && \
+ git-clone $(URL) $(SUBDIR) && \
+ (cd $(SUBDIR) && git-checkout $(VERSION)) && \
+ echo "Packing checkout..." && \
+ rm -rf $(SUBDIR)/.git && \
+ $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+ mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+ )
+endef
+
Validate/svn=VERSION SUBDIR
-#Validate/git=VERSION SUBDIR
+Validate/git=VERSION SUBDIR
define Download/Defaults
URL:=