summaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
commita9136c0892fa5fa1627c2502d309eeb8cda187f8 (patch)
tree626476203a2fc0de4f74dd79615b0f30a850401c /include/depends.mk
parentcaf173f8693cb0ec6a4bf9755caa01482c01f92b (diff)
downloadmaster-31e0f0ae-a9136c0892fa5fa1627c2502d309eeb8cda187f8.tar.gz
master-31e0f0ae-a9136c0892fa5fa1627c2502d309eeb8cda187f8.tar.bz2
master-31e0f0ae-a9136c0892fa5fa1627c2502d309eeb8cda187f8.zip
speed up the build system by including include/shell.sh on shell commands only where necessary
SVN-Revision: 22720
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 65e9b25d5e..828ceb8564 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -13,7 +13,7 @@
DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
-find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
+find_md5=$(SH_FUNC) find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
define rdep
.PRECIOUS: $(2)