summaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-30 21:12:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-30 21:12:39 +0000
commit5f748a6c24863b08652d835c2858acfd83a84238 (patch)
tree7492870ce899ef7791c89ecb4a2b570f9d637be5 /include/depends.mk
parent9566fb1f0701759d499e1579a340943ff5a7422d (diff)
downloadmaster-31e0f0ae-5f748a6c24863b08652d835c2858acfd83a84238.tar.gz
master-31e0f0ae-5f748a6c24863b08652d835c2858acfd83a84238.tar.bz2
master-31e0f0ae-5f748a6c24863b08652d835c2858acfd83a84238.zip
clean up recursive dependency handling, use timestamp.pl again, because it saves memory and execution time
SVN-Revision: 8558
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk46
1 files changed, 31 insertions, 15 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 4819d6dfc1..b488af9271 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -6,26 +6,42 @@
#
# define a dependency on a subtree
# parameters:
-# 1: directory
+# 1: directories/files
# 2: directory dependency
# 3: tempfile for file listings
# 4: find options
-DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*" -type f -not -name ".*" -and -not -path "*.svn*" -and -not -path "*:*" -and -not -path "*!*" -and -not -path "* *" -and -not -path "*\\\#*"
+DEP_FINDPARAMS := -x "*.svn*" -x ".*" -x "*.svn*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
+
+find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
+
define rdep
- $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) $(4)),
- $(2): $(file)
- $(file): ;
- )
+ .PRECIOUS: $(2)
+ .SILENT: $(2)_check
- ifneq ($(3),)
- ifneq ($$(shell find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s),$(if $(3),$(shell cat $(3) || touch $(3) 2>/dev/null)))
- $(2): $(3)
- endif
-
- endif
+ $(2): $(2)_check
+ $(2)_check::
+ if [ -f "$(2)" ]; then \
+ $(if $(3), \
+ $(call find_md5,$(1),$(4)) > $(3).1; \
+ { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
+ ) \
+ { \
+ [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+ $(SCRIPT_DIR)/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+ $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
+ touch -r "$(2)" "$(2)_check"; \
+ } \
+ } || { \
+ $(call debug_eval,$(SUBDIR),r,echo "Need to rebuild $(2)";) \
+ touch "$(2)_check"; \
+ }; \
+ $(if $(3), mv $(3).1 $(3);) \
+ else \
+ $(if $(3), rm -f $(3) $(3).1;) \
+ $(call debug_eval,$(SUBDIR),r,echo "Target $(2) not built";) \
+ true; \
+ fi
- $(3): FORCE
- @-find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
- .PRECIOUS: $(3)
endef
+