summaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-05-09 22:47:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-05-09 22:47:01 +0000
commit56cdcf23a35f80615b40df3481151764aac30089 (patch)
treeead23976c513e2e4f763ed30ba0ef78caf22ffbe /include/depends.mk
parent76184df0e655ad06980fbc72961e9103b188d3eb (diff)
downloadmaster-31e0f0ae-56cdcf23a35f80615b40df3481151764aac30089.tar.gz
master-31e0f0ae-56cdcf23a35f80615b40df3481151764aac30089.tar.bz2
master-31e0f0ae-56cdcf23a35f80615b40df3481151764aac30089.zip
fix recursive dependencies on build directories - should lead to fewer spontaneous rebuilds
SVN-Revision: 7151
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk17
1 files changed, 9 insertions, 8 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 07345a3998..1e01d35f81 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -11,18 +11,19 @@
# 3: tempfile for file listings
# 4: find options
-FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*"
+DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*"
define rdep
- $(foreach file,$(shell find $(1) $(FINDPARAMS) -and -not -path "*:*" $(4)),
+ $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) -and -not -path "*:*" $(4)),
$(2): $(file)
$(file): ;
)
- ifneq ($(shell find $(1) $(FINDPARAMS) $(4) 2>/dev/null | md5s),$(shell cat $(3) 2>/dev/null))
- $(2): $(3)
- endif
+ ifneq ($(3),)
+ ifneq ($$(shell find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s),$(if $(3),$(shell cat $(3) 2>/dev/null)))
+ $(2): $(3)
+ endif
- $(3): FORCE
- @-find $(1) $(FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
-
+ $(3): FORCE
+ @-find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
+ endif
endef