summaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 23:52:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 23:52:17 +0000
commit23f00178291b9ff3006f94dbfed4e44ae3dbf9b6 (patch)
tree549537222badd4aaada4a98c7ff105fad37feb52 /include/depends.mk
parent3125d81ee176d1c2ea8f768517bc1b269e6a872c (diff)
downloadmaster-31e0f0ae-23f00178291b9ff3006f94dbfed4e44ae3dbf9b6.tar.gz
master-31e0f0ae-23f00178291b9ff3006f94dbfed4e44ae3dbf9b6.tar.bz2
master-31e0f0ae-23f00178291b9ff3006f94dbfed4e44ae3dbf9b6.zip
fix a rebuild bug related to quilt
SVN-Revision: 8255
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/depends.mk b/include/depends.mk
index be58ed1cf0..4819d6dfc1 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -19,11 +19,13 @@ define rdep
)
ifneq ($(3),)
- ifneq ($$(shell find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s),$(if $(3),$(shell cat $(3) 2>/dev/null)))
+ ifneq ($$(shell find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s),$(if $(3),$(shell cat $(3) || touch $(3) 2>/dev/null)))
$(2): $(3)
endif
- $(3): FORCE
- @-find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
endif
+
+ $(3): FORCE
+ @-find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
+ .PRECIOUS: $(3)
endef