summaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-26 11:32:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-26 11:32:13 +0000
commit109f15b54cd3932df9b41ad6e681351fe7c5146a (patch)
treea63650481d1b0a3b7f6c2216d92f73ad9232f0ee /include/depends.mk
parent7f952696c7a8ddf296bb821634edaef0d4c4d8fb (diff)
downloadmaster-31e0f0ae-109f15b54cd3932df9b41ad6e681351fe7c5146a.tar.gz
master-31e0f0ae-109f15b54cd3932df9b41ad6e681351fe7c5146a.tar.bz2
master-31e0f0ae-109f15b54cd3932df9b41ad6e681351fe7c5146a.zip
ignore filenames that can cause problems for the recursive dependency handling
SVN-Revision: 8171
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 1e01d35f81..be58ed1cf0 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -11,9 +11,9 @@
# 3: tempfile for file listings
# 4: find options
-DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*"
+DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*" -type f -not -name ".*" -and -not -path "*.svn*" -and -not -path "*:*" -and -not -path "*!*" -and -not -path "* *" -and -not -path "*\\\#*"
define rdep
- $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) -and -not -path "*:*" $(4)),
+ $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) $(4)),
$(2): $(file)
$(file): ;
)