summaryrefslogtreecommitdiffstats
path: root/include/debug.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-30 21:12:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-30 21:12:39 +0000
commit5f748a6c24863b08652d835c2858acfd83a84238 (patch)
tree7492870ce899ef7791c89ecb4a2b570f9d637be5 /include/debug.mk
parent9566fb1f0701759d499e1579a340943ff5a7422d (diff)
downloadmaster-31e0f0ae-5f748a6c24863b08652d835c2858acfd83a84238.tar.gz
master-31e0f0ae-5f748a6c24863b08652d835c2858acfd83a84238.tar.bz2
master-31e0f0ae-5f748a6c24863b08652d835c2858acfd83a84238.zip
clean up recursive dependency handling, use timestamp.pl again, because it saves memory and execution time
SVN-Revision: 8558
Diffstat (limited to 'include/debug.mk')
-rw-r--r--include/debug.mk15
1 files changed, 11 insertions, 4 deletions
diff --git a/include/debug.mk b/include/debug.mk
index 73e6179060..68d70ba093 100644
--- a/include/debug.mk
+++ b/include/debug.mk
@@ -10,12 +10,15 @@
# d: show subdirectory tree
# t: show added targets
# l: show legacy targets
+# r: show autorebuild messages
# v: verbose (no .SILENCE for common targets)
-ifeq ($(DEBUG),all)
- build_debug:=dltv
-else
- build_debug:=$(DEBUG)
+ifeq ($(DUMP),)
+ ifeq ($(DEBUG),all)
+ build_debug:=dltvr
+ else
+ build_debug:=$(DEBUG)
+ endif
endif
define debug
@@ -26,6 +29,10 @@ define warn
$$(if $(call debug,$(1),$(2)),$$(warning $(3)))
endef
+define debug_eval
+$$(if $(call debug,$(1),$(2)),$(3))
+endef
+
define warn_eval
$(call warn,$(1),$(2),$(3) $(4))
$(4)