summaryrefslogtreecommitdiffstats
path: root/include/debug.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 18:22:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 18:22:01 +0000
commit49e628f7652e9f7ce63b932f83b22756a65ff3b9 (patch)
treeda6a7f4c8cc7c3e49b2af71d736762b4bb431fba /include/debug.mk
parent2e072cfb4b9d1818d1bdc98dba70d0d4ff1b56c3 (diff)
downloadmaster-31e0f0ae-49e628f7652e9f7ce63b932f83b22756a65ff3b9.tar.gz
master-31e0f0ae-49e628f7652e9f7ce63b932f83b22756a65ff3b9.tar.bz2
master-31e0f0ae-49e628f7652e9f7ce63b932f83b22756a65ff3b9.zip
next round of build system cleanup - convert package/ to new structure
SVN-Revision: 8236
Diffstat (limited to 'include/debug.mk')
-rw-r--r--include/debug.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/include/debug.mk b/include/debug.mk
new file mode 100644
index 0000000000..73e6179060
--- /dev/null
+++ b/include/debug.mk
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+# debug flags:
+#
+# d: show subdirectory tree
+# t: show added targets
+# l: show legacy targets
+# v: verbose (no .SILENCE for common targets)
+
+ifeq ($(DEBUG),all)
+ build_debug:=dltv
+else
+ build_debug:=$(DEBUG)
+endif
+
+define debug
+$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
+endef
+
+define warn
+$$(if $(call debug,$(1),$(2)),$$(warning $(3)))
+endef
+
+define warn_eval
+$(call warn,$(1),$(2),$(3) $(4))
+$(4)
+endef
+
+