summaryrefslogtreecommitdiffstats
path: root/include/debug.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-03 03:40:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-03 03:40:01 +0000
commit33cde6b296a4f73a2797c53bdf4eff52bc3d4fcc (patch)
treebaa83036e1e7cc2410f4fa447dbd437d34d08373 /include/debug.mk
parent8a0d981006508cbaa3f39a75affd63bdb0f0ff3f (diff)
downloadmaster-31e0f0ae-33cde6b296a4f73a2797c53bdf4eff52bc3d4fcc.tar.gz
master-31e0f0ae-33cde6b296a4f73a2797c53bdf4eff52bc3d4fcc.tar.bz2
master-31e0f0ae-33cde6b296a4f73a2797c53bdf4eff52bc3d4fcc.zip
build: undefine debug helper templates used by subdir.mk if the DEBUG variable is empty, speeds up "make prereq" by 25% when lots of packages are installed
SVN-Revision: 26434
Diffstat (limited to 'include/debug.mk')
-rw-r--r--include/debug.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/debug.mk b/include/debug.mk
index faead042dc..bec74d187a 100644
--- a/include/debug.mk
+++ b/include/debug.mk
@@ -21,6 +21,8 @@ ifeq ($(DUMP),)
endif
endif
+ifneq ($(DEBUG),)
+
define debug
$$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
endef
@@ -38,4 +40,12 @@ $(call warn,$(1),$(2),$(3) $(4))
$(4)
endef
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif