summaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:15 +0000
commitfd53d49f5b8e49cad3a97aae24b779cc4b720006 (patch)
tree1abdbc9ab14f58728f809b8220a5cb4a5dee15a5 /include/cmake.mk
parent7be42a71e1c3cb29890e9ff3bf5286575361e8b6 (diff)
downloadmaster-31e0f0ae-fd53d49f5b8e49cad3a97aae24b779cc4b720006.tar.gz
master-31e0f0ae-fd53d49f5b8e49cad3a97aae24b779cc4b720006.tar.bz2
master-31e0f0ae-fd53d49f5b8e49cad3a97aae24b779cc4b720006.zip
include: cmake: prevent inclusion of rpath in binaries
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44328
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 6ab628ee2e..862a6a9b3f 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -61,6 +61,7 @@ define Build/Configure/Default
-DCMAKE_INSTALL_PREFIX=/usr \
-DDL_LIBRARY=$(STAGING_DIR) \
-DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
+ -DCMAKE_SKIP_RPATH=TRUE \
$(CMAKE_OPTIONS) \
$(CMAKE_SOURCE_DIR) \
)